Ever get this message when running apt-get update: The following signatures couldn’t be verified ?

Apr 29th, 2012 | By | Category: Internet, Linux / Freebsd

Well I just did, infact the full message is:

GPG error: http://us.archive.ubuntu.com lucid Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY ###########

With the #’s being replacing by whatever key number you are given.. obviously this means that you need to update or get a new key.. Easy to do so, just use the following command:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com ##############

Taking the number in the error message and putting that in the above command in the place of the #'s and with that you should be as right as rain

Tags: , , , , ,

Leave a Comment